Auteur Sujet: Compatibility problems with RC4 and PortaMX ?  (Lu 148374 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Road Rash

  • Cynois
  • ***
  • Messages: 20
    • Voir le profil
Lol.
Well, neither do I. I mean, I don't hold any degree whatsoever.
That's not entirely true Nao, you have an angle therefor you have some type of degree :sumanai: :sifflote:

Hors ligne Road Rash

  • Cynois
  • ***
  • Messages: 20
    • Voir le profil
Citer
I got it that you're a fan, but what I see is that she's blaming me before even looking at my code. Doesn't sound like she wants to be friendly.
Nao don't take it too personal. This person has several disabilities that hinder her ability to related humainly with others. First she's a woman, second she's a red head, and third she thinks, (she thinks) she is better than everyone.
People keep saying it's a language barrier, clearly as pointed out by others, a bitch is a bitch no matter what their language or nationality.
Kindred displays the same personality defects. Mayhap he's in drag?

Hors ligne AngelinaBelle

  • Cynois
  • ***
  • Messages: 29
    • Voir le profil
This person has several disabilities that hinder her ability to related humainly[sic] with others. First she's a woman
Seriously?

But I fear this type of comment might be OT.

Hors ligne Road Rash

  • Cynois
  • ***
  • Messages: 20
    • Voir le profil
Please don't take it out of context, all factors apply to make the point. One factor alone is just that. An oatmeal chocolate chip cookie is not as stated without the chocolate chips.   :cool:

Hors ligne Arebias

  • Newbie
  • *
  • Messages: 4
    • Voir le profil
The following is a quote from me on the SMF site.

This is located here: http://www.simplemachines.org/...c=200401.msg2877373#msg2877373
I am here to report a bug with Aeva as it relates to 2.0 RC4. I tried the official site for the mod at http://aeva.noisen.com/ but I don't seem to be able to create a new topic on that immensely confusing site.

Here is a link to the thread that has all the problems associated with the 'Bug'. I assume it is a bug with Aeva but it could be a bug with SMF. I am not knowledgeable enough to determine that. After reading your topic on the relationship with the SMF team I will let you determine that.

http://www.simplemachines.org/...unity/index.php?topic=412512.0
Posté : 10 Décembre 2010 à 21h07


Testing that bug here on your site with Aeva installed.





Yep. It's here too!



Hors ligne Arantor

  • Cynois
  • ***
  • Messages: 603
  • Sexe: Homme
  • Innovate, not Imitate
    • Voir le profil
    • Arantorhome
The reason you can't create a new topic here is that there isn't free support here for Aeva, basically.


Oh, and that's not an Aeva bug you refer to, you cannot put a [url] tag inside an [img] one, plain and simple. The parser should be preventing it from happening. As you would find if you tried it on that forum, i.e. one without Aeva.

In theory it should never have parsed properly, but as of the changes in 2.0 RC3 and 1.1.11 (note: not even the latest versions), it should have been doubly disabled for security reasons to avoid malformed URL and XSS vulnerabilities.

You can't put tags inside tags, it's invalid HTML so it doesn't work. Better question is why it *ever* worked before.


Try it on simplemachines.org. They don't have Aeva. Funny though, it won't work there either. I wonder why... is it because it's an SMF issue with your messed up code perhaps?

Even the SMF team are telling you it's not an Aeva bug!


:edit: Since I'm feeling nice, here's a thought. I doubt the SMF folks would either know about this or bother to investigate.

Subs.php
Code: (find) [Sélectionner]
$no_autolink_tags = array(
'url',
'iurl',
'ftp',
'email',
);

Code: (replace) [Sélectionner]
$no_autolink_tags = array(
'url',
'iurl',
'ftp',
'email',
'img',
);
« Modifié à 21h27 »
   computer-aided
   community building
             
Other stuff:

Hors ligne Arebias

  • Newbie
  • *
  • Messages: 4
    • Voir le profil
Oh, and that's not an Aeva bug you refer to, you cannot put a [url] tag inside an [img] one, plain and simple. The parser should be preventing it from happening. As you would find if you tried it on that forum, i.e. one without Aeva.


Try it on simplemachines.org. They don't have Aeva. Funny though, it won't work there either. I wonder why... is it because it's an SMF issue with your messed up code perhaps?

Even the SMF team are telling you it's not an Aeva bug!
That is not true. In a few parts.

This code does work just fine on the SMF site.

[center][url=http://www.gametracker.com/server_info/63.251.20.161:27960/][img][url=http://cache.[url=http://www.gametracker.com/server_info/63.251.20.161:27960/b_560_95_1.png]www.gametracker.com/server_info/63.251.20.161:27960/b_560_95_1.png[/url]]www.gametracker.com/server_info/63.251.20.161:27960/b_560_95_1.png[/url][/img][/url][/center]

Shows up just fine!

And now that I removed Aeva 100% from my site it works just fine there as well.


As far as the team not recognizing this as being a SMF problem, I use that word loosely because they don't see this as a problem since this is not a widely used format for URL's, they did if you read the whole post'.

Didn't I just go over this with someone?

This is a problem with smf (sort of) not with aeva.
mostly, it's a problem with that website ont using a standard url address format.

The problem is that smf interprets www as the START of a web address,
so it is attempting to make the URL that is SEES into a link because that
cache.www screws it up.


I honestly don't call this an actual SMF "bug" and I would prefer telling the
stupid people who used that format or url to use a proper format.

And as far as the code being involved in this. It looks as though it is this code in Sources/Subs-Aeva.php:


// Links urls that haven't already been linked
function aeva_autolink_urls($input)
{
   global $context, $modSettings;

   // Should haven't got here if autolinking of urls is disabled
   if (empty($modSettings['autoLinkUrls']))
      return $input;


Because when changed to this it works:

// Links urls that haven't already been linked
function aeva_autolink_urls($input)
{
   global $context, $modSettings;

   // Should haven't got here if autolinking of urls is disabled
   if (empty($modSettings['autoLinkUrls']))
      return $input;
     
   if (preg_match("/gametracker/i", $input))
      return $input;


The code changes and ID of the location causing problems is courtesy of XerraX btw


« Modifié à 22h49 »

Hors ligne Arantor

  • Cynois
  • ***
  • Messages: 603
  • Sexe: Homme
  • Innovate, not Imitate
    • Voir le profil
    • Arantorhome
And you didn't bother to check the code I used?

It's all kind of irrelevant anyway since let's be clear, Nao and I aren't supporting SMF, we're working on our own thing, and of that, we're going to be doing some serious rewriting of SMF, which means we're going to be rewriting the bbc system eventually anyway, as well as parts of Aeva.

(And yes, cache.www is a stupid URL system.)

But hey, you got a solution to your problem, hope you feel good now.
   computer-aided
   community building
             
Other stuff:

Hors ligne Arebias

  • Newbie
  • *
  • Messages: 4
    • Voir le profil
Well yes I guess I do. I am working on that right now. I don't have that Sources/Subs-Aeva.php on the version I installed. lol

I don't know where that code is located. I am trying to find it now.

I don't exactly understand the whole situation between you guys and SMF so I apologize if I came in here and was interpreted as trying to cause problems. My intention was just to bring up a problem that I was experiencing, as well as others, without trying to point fingers. I appreciate what all the modders and coders are able to do and maybe one day I can reach that level also before I die. I am getting a late start. lol


And btw; I did try your code fix and it did not work on that particular link format.


« Modifié à 23h03 »

Hors ligne Arantor

  • Cynois
  • ***
  • Messages: 603
  • Sexe: Homme
  • Innovate, not Imitate
    • Voir le profil
    • Arantorhome
Citer
I don't have that Sources/Subs-Aeva.php on the version I installed. lol
Well, I have no idea what version of Aeva you're using so no idea what to be looking for, since there are three principle versions, Aeva Lite, Aeva Media 1.x and Aeva Media 2.x, of which only the last one is really receiving support (paid, though) and the other two only get support here if Nao or I can be bothered, which isn't all that often, really.

The fact my fix didn't work wasn't useless, either, it just clarified where exactly the issue is (since there are times this can happen in raw SMF too!)
   computer-aided
   community building
             
Other stuff:

Hors ligne Arebias

  • Newbie
  • *
  • Messages: 4
    • Voir le profil

Yeah I got the version thing figured out now. I installed the 'lite' version on my other test site and was able to make the changes to the code that the other guy suggested and that works just fine for that particular site in question with that particular format of url.

Good luck on future work and thanks for all the work in the past.

Hors ligne live627

  • Cynois
  • ***
  • Messages: 14
    • Voir le profil
Citer
Feline found an error:

"The bug has to do with the new integration hooks in RC4.
If Aeva make his ob_start, ob_end, the SMF outbuffer is called twice in ONE session, so a dynamic function then is created on the first outbuffer call and  exists on the second call. This crashed the entire system."
I wonder what she would say if she found Dream Portal uses output buffering...

Hors ligne Arantor

  • Cynois
  • ***
  • Messages: 603
  • Sexe: Homme
  • Innovate, not Imitate
    • Voir le profil
    • Arantorhome
She'd probably ask who on the team has a degree in CompSci and try to pretend you don't know what you're on about.
   computer-aided
   community building
             
Other stuff:

Hors ligne live627

  • Cynois
  • ***
  • Messages: 14
    • Voir le profil
She obviously has one. (No one on the DP team has one btw)

Hors ligne Arantor

  • Cynois
  • ***
  • Messages: 603
  • Sexe: Homme
  • Innovate, not Imitate
    • Voir le profil
    • Arantorhome
Bingo. If you want a laugh, go read pages 7-10 or so of the SimpleSEF thread where he tries to get all high and mighty with SlammedDime.
   computer-aided
   community building
             
Other stuff: